名前重要

Get というメンバ関数がある。何を Get するというのだろう。 ConditionChange というクラスがある。何のコンディションを変更するというのだろう。

もうちょっとまともな名前を付けたほうが、後々いいのではないかと思うわけですが。

Get というメンバ関数を持つクラスは Singleton になっていて、その唯一のインスタンスを返す関数になっているようです。 GetInstance ではないのは、入力が面倒くさいからなのかな。

ちなみにそのメンバにさらに Ptr なんてものがあるので、 Hoge::Get()->Ptr->foo... なんて最早知らない人には読めないソースになりつつあるような気がします。ま、自分が触ることはないだろうし、別にいいんですけどね。勝手に読んで勝手に感想を言っているだけなので(なんか陰湿だな(笑)。